Notizia Precedente
System Explorer 5.5.0
Notizia Successiva
Linux Kernel 3.15 RC2

Drupal 7.27

Naviga SWZ: Home Page » News
News del 22 Aprile 14 Autore: Gianplugged
Drupal 7.27
Drupal è un CMS (Content Management System) Open Source scritto in linguaggio PHP e molto popolare. Il software è particolarmente scalabile, tanto da essere utilizzato si da singoli Utenti fino a grandissime aziende e organizzazioni.

Drupal offre un´interfaccia di amministrazione con cui l´amministratore può gestire ogni aspetto del sito web, senza il bisogno di possedere particolari conoscenze tecniche.

Note di rilascio:

Maintenance and security release of the Drupal 7 series.

This release fixes security vulnerabilities. Sites are urged to upgrade immediately after reading the security announcement:

SA-CORE-2014-002 - Drupal core - Information Disclosure
No other fixes are included.

No changes have been made to the .htaccess, web.config, robots.txt or default settings.php files in this release, so upgrading custom versions of those files is not necessary.

Known issues:

See below for small API changes which may affect sites that expose Ajax or multi-step forms to anonymous users on cached pages (where the page is cached either by Drupal or by an external system). In most cases, serious regressions are not expected and the changes are not critical, but they could be required for anonymous users to be able to properly use these Ajax or multi-step forms.
This release caused a JavaScript error which breaks Ajax requests in very old browsers (for example, Internet Explorer 8 and earlier). A fix is available in this issue and will be included in the next bug fix release of Drupal core. Sites which need the fix sooner can apply the patch from that issue to their Drupal 7.27 sites.
Major changes since 7.26:

Modules which use custom Ajax form page callbacks require updates for Drupal 7.27
This is expected to affect several popular modules such as Field Collection (issue) and Hierarchical Select (issue), although only in cases where the form widgets provided by those modules are exposed to anonymous users.

Modules which provide alternative page cache implementations require updates for Drupal 6.31 and Drupal 7.27
This is expected to affect modules such as Boost and Authcache.

form_set_cache() now validates the passed-in form build ID
This is not expected to affect most sites.
Inserisci un commento sul forum Commenta la News sul Forum


Categoria: P2P e Web

Licenza: Open Source

La Community di

La community con le risposte che cerchi ! Partecipa é gratis !
Iscrizione ForumIscriviti al Forum


Vuoi ricevere tutti gli aggiornamenti di SWZone direttamente via mail ?
Iscrizione NewsletterIscriviti alla Newsletter

Carico il Player Video